Combinația care prevestește nenorocirea WordPress – Jetpack, Yoast, Shield

Pluginurile WordPress au fost dintotdeauna motiv pentru instabilitate și nu le-am plăcut niciodată. Din punctul meu de vedere nu aș folosi nici un plugin dacă nu aș fi nevoit, nici măcar celebrul Askimet.

Problema este că WordPress funcționează pe bază de asemenea module – pluginuri și nu ai ce să faci, ai nevoie de un plugin anti SPAM, ai nevoie de un plugin care să-ți posteze automat pe rețelele sociale, ai nevoie de un plugin SEO și așa mai departe. Pentru un blog destul de măricel cred că se adună undeva la 10 pluginuri cu timpul, pe măsură ce-ți dai seama că mai ai nevoie de ceva…

Din păcate, pluginurile sunt generatoare de instabilitate din două puncte de vedere:

  1. Reprezintă vulnerabilitate. Site-urile WordPress sunt foarte vulnerabile în fața hackerilor din cauza acestor pluginuri care nu pot fi updatate la secundă de către deținătorul site-ului. Dacă nu fac update la timp la pluginuri, te poți trezi când îți e lumea mai dragă cu scripturi de SPAM printre fișierele de bază ale WordPress. Găzduirea îți va fi suspendată și de aici o întreagă nebunie.
  2. Sunt mari cauzatoare de blank page of death. În momentul în care faci update la un plugin, există mari șanse ca lucrurile să meargă prost, iar site-ul să nu mai funcționeze. Apare o pagină albă în loc de homepage-ul tău și de multe ori nu te mai poți nici loga.

Jetpack, Yoast, Shield

Cei 3 muschetari mari cauzatori de probleme. Când vezi triada asta la Update Plugins, fă un backup prima dată. Apoi, cu Dumnezeu înainte, cu rugăciunea Tatăl Nostru spusă de vreo 2 ori, poți începe să faci update. Pregătește din timp FTP ca să poți rezolva blank page of death dacă apare, sunt șanse mari să apară…

Articole Recomandate

About The Author

  • ADD YOUR COMMENT